Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 19, 2025 - 19:00 CET
Scheduled
Hello everyone,
On November 19th, we will be performing important maintenance at our Spain location. The maintenance window will be from 7:00 PM to 3:00 AM (CEST).
During this time, there may be temporary interruptions in game server availability. We’ll do our best to complete the work as quickly as possible to restore full service.
Thank you for your understanding, Your 4Netplayers Team
Posted Nov 12, 2025 - 14:12 CET
This scheduled maintenance affected: Gameserver EU (Madrid, Spain).